Comments on: Aptitude Madness https://pthree.org/2012/06/14/aptitude-madness/ Linux. GNU. Freedom. Tue, 31 Oct 2017 18:00:46 +0000 hourly 1 https://wordpress.org/?v=5.0-alpha-42127 By: Soren Hansen https://pthree.org/2012/06/14/aptitude-madness/#comment-116657 Wed, 20 Jun 2012 06:59:13 +0000 http://pthree.org/?p=2399#comment-116657 I never said installing virtinst is a niche use case. I'm not sure where you're getting that.

I'm saying that installing only virtinst and its strict dependencies indeed does give you a tool that can perform some function, namely performing unattended installations of a networking impaired operating system on a remote hypervisor. I maintain that this is a niche use case.

Sure, you can manually install kvm and bridge-utils etc. and actually end up with a complete toolset that will be useful. I just believe it's better to give users what they *probably* want, assuming they're anything like 95% of other users of the package, rather than leave them guessing at that set of packages.

As for your argument about virt-viewer being a client package and hence being unnecessary... What do you think virt-install is?

]]>
By: Aaron Toponce https://pthree.org/2012/06/14/aptitude-madness/#comment-116602 Fri, 15 Jun 2012 06:14:22 +0000 http://pthree.org/?p=2399#comment-116602 A niche? All I want is virt-install. I just want the ability to create virtual machines in the command line, without virt-manager. So, I'm curious why installing the virtinst package, which provides virt-install, is a niche use case. So, feel free to install colord, libxinerama1, sane-utils so you can install virtual machines. I'll stick with just the software that is actually needed to pull off the function, and not provide a ton of bloat.

And what's all this talk about refusing to install a hypervisor, virt-viewer or bridge-utils? I have KVM installed, as well as bridge-utils. How else am I supposed to build out a hypervisor? And why do I need virt-viewer on the hypervisor? It's a client package, and an unnecessary one at that. Using virt-manager, you can get access to the console of the VM just fine. Even using "virsh console" on the server works. So, I'm not exactly sure what you're saying.

]]>
By: Soren Hansen https://pthree.org/2012/06/14/aptitude-madness/#comment-116599 Fri, 15 Jun 2012 00:11:13 +0000 http://pthree.org/?p=2399#comment-116599 I'm not sure what the problem you're alluding to is.

Without those recommended packages, it's unlikely that you'll be able to use virtinst for anything useful:

* You've refused to let it install a hypervisor, so you can only do remote installs. This is almost never what anyone wants to do with virtinst.
* Even if you happened to already have a hypervisor installed (or if you specificed it explicitly in the apt-get command), you would only be able to do automated installs, because you've refused to let it install virt-viewer (needed to connect you to the console of the VM being installed).
* Had you not already had bridge-utils installed, you wouldn't be able to connect your VM's to the network, but be stuck with user-mode networking. Noone wants user-mode networking.

So yes, congratulations, you've installed a piece of software which is useless for all but niche use cases. Meanwhile, the rest of us enjoy things being useful by default.

]]>
By: Andreas Olsson https://pthree.org/2012/06/14/aptitude-madness/#comment-116598 Thu, 14 Jun 2012 14:59:02 +0000 http://pthree.org/?p=2399#comment-116598 Myself I am kind of thorn regarding installing Recommends by default. Apart from the illustrated problems, it does have the benefit of making it easier to move stuff from being Dependencies to being Recommends, allowing you to either skip all the Recommends, or afterwards removing a few Recommended packages, without forcing the original package to be removed.

]]>
By: Aaron Toponce https://pthree.org/2012/06/14/aptitude-madness/#comment-116597 Thu, 14 Jun 2012 14:14:43 +0000 http://pthree.org/?p=2399#comment-116597 Thanks for the recommendation. Doesn't change the draconian nature of installing recommends by default.

]]>
By: Andreas Olsson https://pthree.org/2012/06/14/aptitude-madness/#comment-116596 Thu, 14 Jun 2012 13:58:52 +0000 http://pthree.org/?p=2399#comment-116596 May I suggest the following apt config?

APT::Install-Recommends "false";

]]>